re = /([a-zA-Z])[^.]*\.([a-zA-Z]).*?\b/
str = 'New.York new.york '
subst = '\\1.\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result