import Foundation
let pattern = #"([a-zA-Z])[^.]*\.([a-zA-Z]).*?\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"New.York new.york "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1.\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)