using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z])[^.]*\.([a-zA-Z]).*?\b";
string substitution = @"\1.\2";
string input = @"New.York new.york ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}