#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([a-zA-Z])[^.]*\.([a-zA-Z]).*?\b"
Local $sString = "New.York new.york "
Local $sSubst = "\1.\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)