import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\/([^_].*\\.scss)$";
final String string = "sass\n"
+ "sass/index.scss\n"
+ "sass/_estructura.scss\n"
+ "sass/_tema.scss\n"
+ "sass/_texto.scss\n"
+ "sass/_fonts.scss\n"
+ "sass/juegos.scss";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}