const regex = /^.*\/([^_].*\.scss)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\\/([^_].*\\.scss)$', 'mg')
const str = `sass
sass/index.scss
sass/_estructura.scss
sass/_tema.scss
sass/_texto.scss
sass/_fonts.scss
sass/juegos.scss`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}