$re = '/^.*\/([^_].*\.scss)$/m';
$str = 'sass
sass/index.scss
sass/_estructura.scss
sass/_tema.scss
sass/_texto.scss
sass/_fonts.scss
sass/juegos.scss';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);