re = /^.*\/([^_].*\.scss)$/m
str = 'sass
sass/index.scss
sass/_estructura.scss
sass/_tema.scss
sass/_texto.scss
sass/_fonts.scss
sass/juegos.scss'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end