#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^PO[\#\s-]\s?\d{2}[\s-]{0,1}\d{4}$"
Local $sString = "PO 11-1111" & @CRLF & _
"PO-11-1111" & @CRLF & _
"PO# 11 1111" & @CRLF & _
"PO#11-1111" & @CRLF & _
"PO 111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")