package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^PO[\#\s-]\s?\d{2}[\s-]{0,1}\d{4}$`)
var str = `PO 11-1111
PO-11-1111
PO# 11 1111
PO#11-1111
PO 111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}