$re = '/^PO[\#\s-]\s?\d{2}[\s-]{0,1}\d{4}$/m';
$str = 'PO 11-1111
PO-11-1111
PO# 11 1111
PO#11-1111
PO 111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);