using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^PO[\#\s-]\s?\d{2}[\s-]{0,1}\d{4}$";
string input = @"PO 11-1111
PO-11-1111
PO# 11 1111
PO#11-1111
PO 111111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}