re = /^PO[\#\s-]\s?\d{2}[\s-]{0,1}\d{4}$/m
str = 'PO 11-1111
PO-11-1111
PO# 11 1111
PO#11-1111
PO 111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end