import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^PO[\\#\\s-]\\s?\\d{2}[\\s-]{0,1}\\d{4}$";
final String string = "PO 11-1111\n"
+ "PO-11-1111\n"
+ "PO# 11 1111\n"
+ "PO#11-1111\n"
+ "PO 111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}