# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)<sup>†<\\/sup>(.*)|(.*)/$1$2$3/gm;t' <<< "$128.48 One Month TV Internet and Voice, 100GB of Fiber<sup>†</sup> Internet.
$148.48 One Month TV Internet and Voice, 200GB of Fiber<sup>†</sup> Internet and a free movie rental from MoviePlex.
$128.48 One Month TV Internet and Voice, 100GB of Fiber Internet. <- without superscript"