# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)<sup>†<\/sup>(.*)|(.*)"
test_str = ("$128.48 One Month TV Internet and Voice, 100GB of Fiber<sup>†</sup> Internet.\n\n"
"$148.48 One Month TV Internet and Voice, 200GB of Fiber<sup>†</sup> Internet and a free movie rental from MoviePlex.\n\n"
"$128.48 One Month TV Internet and Voice, 100GB of Fiber Internet. <- without superscript")
subst = "$1$2$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.