package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)<sup>†<\/sup>(.*)|(.*)`)
var str = `$128.48 One Month TV Internet and Voice, 100GB of Fiber<sup>†</sup> Internet.
$148.48 One Month TV Internet and Voice, 200GB of Fiber<sup>†</sup> Internet and a free movie rental from MoviePlex.
$128.48 One Month TV Internet and Voice, 100GB of Fiber Internet. <- without superscript`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}