import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)<sup>†<\\/sup>(.*)|(.*)";
final String string = "$128.48 One Month TV Internet and Voice, 100GB of Fiber<sup>†</sup> Internet.\n\n"
+ "$148.48 One Month TV Internet and Voice, 200GB of Fiber<sup>†</sup> Internet and a free movie rental from MoviePlex.\n\n"
+ "$128.48 One Month TV Internet and Voice, 100GB of Fiber Internet. <- without superscript";
final String subst = "$1$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}