const regex = /(.*)<sup>†<\/sup>(.*)|(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)<sup>†<\\\/sup>(.*)|(.*)', 'gm')
const str = `\$128.48 One Month TV Internet and Voice, 100GB of Fiber<sup>†</sup> Internet.
\$148.48 One Month TV Internet and Voice, 200GB of Fiber<sup>†</sup> Internet and a free movie rental from MoviePlex.
\$128.48 One Month TV Internet and Voice, 100GB of Fiber Internet. <- without superscript`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);