re = /(.*)<sup>†<\/sup>(.*)|(.*)/m
str = '$128.48 One Month TV Internet and Voice, 100GB of Fiber<sup>†</sup> Internet.
$148.48 One Month TV Internet and Voice, 200GB of Fiber<sup>†</sup> Internet and a free movie rental from MoviePlex.
$128.48 One Month TV Internet and Voice, 100GB of Fiber Internet. <- without superscript'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result