import Foundation
let pattern = #"(.*)<sup>†<\/sup>(.*)|(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$128.48 One Month TV Internet and Voice, 100GB of Fiber<sup>†</sup> Internet.
$148.48 One Month TV Internet and Voice, 200GB of Fiber<sup>†</sup> Internet and a free movie rental from MoviePlex.
$128.48 One Month TV Internet and Voice, 100GB of Fiber Internet. <- without superscript
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)