#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)url\((?:['"]?)(.*?)(?:['"]?)\)"
Local $sString = "@font-face {" & @CRLF & _
" font-family: 'MagistralBlack';" & @CRLF & _
" src: url('../fonts/MagistralBlack.eot?') format("eot")," & @CRLF & _
" url("../fonts/MagistralBlack.woff") format('woff')," & @CRLF & _
" url('../fonts/MagistralBlack.ttf') format('truetype');" & @CRLF & _
" font-weight: 700;" & @CRLF & _
" font-style: normal;" & @CRLF & _
" background: #fe2b58 url(../img/button__shadow.png) center no-repeat;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" font-style: normal; <a href="/docs.php">Documentation</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")