# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"url\((?:['\"]?)(.*?)(?:['\"]?)\)"
test_str = ("@font-face {\n"
" font-family: 'MagistralBlack';\n"
" src: url('../fonts/MagistralBlack.eot?') format(\"eot\"),\n"
" url(\"../fonts/MagistralBlack.woff\") format('woff'),\n"
" url('../fonts/MagistralBlack.ttf') format('truetype');\n"
" font-weight: 700;\n"
" font-style: normal;\n"
" background: #fe2b58 url(../img/button__shadow.png) center no-repeat;\n"
"}\n\n\n"
" font-style: normal; <a href=\"/docs.php\">Documentation</a>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.