re = /url\((?:['"]?)(.*?)(?:['"]?)\)/m
str = '@font-face {
font-family: \'MagistralBlack\';
src: url(\'../fonts/MagistralBlack.eot?\') format("eot"),
url("../fonts/MagistralBlack.woff") format(\'woff\'),
url(\'../fonts/MagistralBlack.ttf\') format(\'truetype\');
font-weight: 700;
font-style: normal;
background: #fe2b58 url(../img/button__shadow.png) center no-repeat;
}
font-style: normal; <a href="/docs.php">Documentation</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end