import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\((?:['\"]?)(.*?)(?:['\"]?)\\)";
final String string = "@font-face {\n"
+ " font-family: 'MagistralBlack';\n"
+ " src: url('../fonts/MagistralBlack.eot?') format(\"eot\"),\n"
+ " url(\"../fonts/MagistralBlack.woff\") format('woff'),\n"
+ " url('../fonts/MagistralBlack.ttf') format('truetype');\n"
+ " font-weight: 700;\n"
+ " font-style: normal;\n"
+ " background: #fe2b58 url(../img/button__shadow.png) center no-repeat;\n"
+ "}\n\n\n"
+ " font-style: normal; <a href=\"/docs.php\">Documentation</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}