using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\((?:['""]?)(.*?)(?:['""]?)\)";
string input = @"@font-face {
font-family: 'MagistralBlack';
src: url('../fonts/MagistralBlack.eot?') format(""eot""),
url(""../fonts/MagistralBlack.woff"") format('woff'),
url('../fonts/MagistralBlack.ttf') format('truetype');
font-weight: 700;
font-style: normal;
background: #fe2b58 url(../img/button__shadow.png) center no-repeat;
}
font-style: normal; <a href=""/docs.php"">Documentation</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}