const regex = /url\((?:['"]?)(.*?)(?:['"]?)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('url\\((?:[\'"]?)(.*?)(?:[\'"]?)\\)', 'gm')
const str = `@font-face {
font-family: 'MagistralBlack';
src: url('../fonts/MagistralBlack.eot?') format("eot"),
url("../fonts/MagistralBlack.woff") format('woff'),
url('../fonts/MagistralBlack.ttf') format('truetype');
font-weight: 700;
font-style: normal;
background: #fe2b58 url(../img/button__shadow.png) center no-repeat;
}
font-style: normal; <a href="/docs.php">Documentation</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}