// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)url\((?:['"]?)(.*?)(?:['"]?)\)"#).unwrap();
let string = "@font-face {
font-family: 'MagistralBlack';
src: url('../fonts/MagistralBlack.eot?') format(\"eot\"),
url(\"../fonts/MagistralBlack.woff\") format('woff'),
url('../fonts/MagistralBlack.ttf') format('truetype');
font-weight: 700;
font-style: normal;
background: #fe2b58 url(../img/button__shadow.png) center no-repeat;
}
font-style: normal; <a href=\"/docs.php\">Documentation</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}