use strict;
my $str = '@font-face {
font-family: \'MagistralBlack\';
src: url(\'../fonts/MagistralBlack.eot?\') format("eot"),
url("../fonts/MagistralBlack.woff") format(\'woff\'),
url(\'../fonts/MagistralBlack.ttf\') format(\'truetype\');
font-weight: 700;
font-style: normal;
background: #fe2b58 url(../img/button__shadow.png) center no-repeat;
}
font-style: normal; <a href="/docs.php">Documentation</a>';
my $regex = qr/url\((?:['"]?)(.*?)(?:['"]?)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}