# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<num1>\d*)?a?(?<num2>\d*)?b?(?<num3>\d*)//gm;t' <<< "111a222b333
111
111b333"