// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<num1>\d*)?a?(?<num2>\d*)?b?(?<num3>\d*)").unwrap();
let string = "111a222b333
111
111b333";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}