$re = '/(?<num1>\d*)?a?(?<num2>\d*)?b?(?<num3>\d*)/m';
$str = '111a222b333
111
111b333';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;