package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<num1>\d*)?a?(?<num2>\d*)?b?(?<num3>\d*)`)
var str = `111a222b333
111
111b333`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}