use strict;
my $str = '111a222b333
111
111b333';
my $regex = qr/(?<num1>\d*)?a?(?<num2>\d*)?b?(?<num3>\d*)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";