const regex = /(?<num1>\d*)?a?(?<num2>\d*)?b?(?<num3>\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<num1>\\d*)?a?(?<num2>\\d*)?b?(?<num3>\\d*)', 'gm')
const str = `111a222b333
111
111b333`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);