using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<num1>\d*)?a?(?<num2>\d*)?b?(?<num3>\d*)";
string substitution = @"";
string input = @"111a222b333
111
111b333";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}