#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*(\w[\W\w]{0,28}\w)\b\s*"
Local $sString = " Your veryyyyyyyyy long first and last name goes here" & @CRLF & _
"" & @CRLF & _
"As you can see, only the first 30 characters are selected," & @CRLF & _
"which also has to begin and end with a word character." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")