$re = '/\s*(\w[\W\w]{0,28}\w)\b\s*/';
$str = ' Your veryyyyyyyyy long first and last name goes here
As you can see, only the first 30 characters are selected,
which also has to begin and end with a word character.
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);