import re
regex = re.compile(r"\s*(\w[\W\w]{0,28}\w)\b\s*")
test_str = (" Your veryyyyyyyyy long first and last name goes here\n\n"
"As you can see, only the first 30 characters are selected,\n"
"which also has to begin and end with a word character.\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")