re = /\s*(\w[\W\w]{0,28}\w)\b\s*/
str = ' Your veryyyyyyyyy long first and last name goes here
As you can see, only the first 30 characters are selected,
which also has to begin and end with a word character.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end