const regex = /\s*(\w[\W\w]{0,28}\w)\b\s*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(\\w[\\W\\w]{0,28}\\w)\\b\\s*', '')
const str = ` Your veryyyyyyyyy long first and last name goes here
As you can see, only the first 30 characters are selected,
which also has to begin and end with a word character.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}