import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\\w[\\W\\w]{0,28}\\w)\\b\\s*";
final String string = " Your veryyyyyyyyy long first and last name goes here\n\n"
+ "As you can see, only the first 30 characters are selected,\n"
+ "which also has to begin and end with a word character.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}