using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(\w[\W\w]{0,28}\w)\b\s*";
string input = @" Your veryyyyyyyyy long first and last name goes here
As you can see, only the first 30 characters are selected,
which also has to begin and end with a word character.
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}