// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*(\w[\W\w]{0,28}\w)\b\s*").unwrap();
let string = " Your veryyyyyyyyy long first and last name goes here
As you can see, only the first 30 characters are selected,
which also has to begin and end with a word character.
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}