#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(.+\B)\s+(\1(\s+)?)+"
Local $sString = "Hey salut a tous les amis ! Hey salut a tous les amis ! #" & @CRLF & _
"salut a tous les amis ! Hey salut a tous les amis !" & @CRLF & _
"salut a tous les amis ! Hey salut a tous les amis ! #" & @CRLF & _
"" & @CRLF & _
"Comment allez vous ?" & @CRLF & _
"Bien et toi ?" & @CRLF & _
"Bien et toi ? #" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Comment allez vous ? #" & @CRLF & _
"" & @CRLF & _
"Comment allez vous ? #" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"" & @CRLF & _
"Salut comment vas ? Salut comment vas ? #" & @CRLF & _
"a" & @CRLF & _
"" & @CRLF & _
"Salut ça va? salut ça va? #"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")