using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+\B)\s+(\1(\s+)?)+";
string input = @"Hey salut a tous les amis ! Hey salut a tous les amis ! #
salut a tous les amis ! Hey salut a tous les amis !
salut a tous les amis ! Hey salut a tous les amis ! #
Comment allez vous ?
Bien et toi ?
Bien et toi ? #
Comment allez vous ? #
Comment allez vous ? #
a
Salut comment vas ? Salut comment vas ? #
a
Salut ça va? salut ça va? #";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}