use strict;
my $str = 'Hey salut a tous les amis ! Hey salut a tous les amis ! #
salut a tous les amis ! Hey salut a tous les amis !
salut a tous les amis ! Hey salut a tous les amis ! #
Comment allez vous ?
Bien et toi ?
Bien et toi ? #
Comment allez vous ? #
Comment allez vous ? #
a
Salut comment vas ? Salut comment vas ? #
a
Salut ça va? salut ça va? #';
my $regex = qr/(.+\B)\s+(\1(\s+)?)+/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}