import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+\\B)\\s+(\\1(\\s+)?)+";
final String string = "Hey salut a tous les amis ! Hey salut a tous les amis ! #\n"
+ "salut a tous les amis ! Hey salut a tous les amis !\n"
+ "salut a tous les amis ! Hey salut a tous les amis ! #\n\n"
+ "Comment allez vous ?\n"
+ "Bien et toi ?\n"
+ "Bien et toi ? #\n\n\n"
+ "Comment allez vous ? #\n\n"
+ "Comment allez vous ? #\n\n"
+ "a\n\n"
+ "Salut comment vas ? Salut comment vas ? #\n"
+ "a\n\n"
+ "Salut ça va? salut ça va? #";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}