$re = '/(.+\B)\s+(\1(\s+)?)+/mi';
$str = 'Hey salut a tous les amis ! Hey salut a tous les amis ! #
salut a tous les amis ! Hey salut a tous les amis !
salut a tous les amis ! Hey salut a tous les amis ! #
Comment allez vous ?
Bien et toi ?
Bien et toi ? #
Comment allez vous ? #
Comment allez vous ? #
a
Salut comment vas ? Salut comment vas ? #
a
Salut ça va? salut ça va? #';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);