const regex = new RegExp('(.+\\B)\\s+(\\1(\\s+)?)+', 'gmi')
const str = `Hey salut a tous les amis ! Hey salut a tous les amis ! #
salut a tous les amis ! Hey salut a tous les amis !
salut a tous les amis ! Hey salut a tous les amis ! #
Comment allez vous ?
Bien et toi ?
Bien et toi ? #
Comment allez vous ? #
Comment allez vous ? #
a
Salut comment vas ? Salut comment vas ? #
a
Salut ça va? salut ça va? #`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}